Topic: Preview Bug Report: Incomplete Viewer in IE11

Report Abuse Report Abuse
NateLawrence (Over 1 year ago)
Early this morning I tried to load some synths on a family member's laptop I'd borrowed. I discovered that the viewer never initialized, no matter what new synth I navigated to.

The Info, Share, and Favorite as well as the Play and Fullscreen icons would load against the default grey backdrop, but never anything else.

My typical practice is to simply use a Private Mode window so that I can sign into the site and comment without disturbing anyone else's cookies, but what was the case this morning was that in any Private Mode window in IE11, the site loaded and the viewer worked, however in a normal window it never loaded the viewer.

I tried hard refreshing various viewer pages repeatedly, disabling all add-ons, flushing the cache, and finally resetting all IE custom settings all to no avail.
NateLawrence (Over 1 year ago)
The problem did not manifest when I activated the Guest desktop user account, so the bug was specific to the main user's desktop but did not resolve with browser closing + opening or multiple laptop reboots. 

Finally I tried flushing the cache a second time after I'd tried the Guest mode account, logged out of it and confirmed that the default user account continued to not work in a default window + tried closing and re-opening the browser there without any visible change and after this second cache flush the viewer did begin to load again outside of Private Mode windows.

All other browsers never experienced the issue nor did IE11 windows on the only other desktop account on the same machine.
NateLawrence (Over 1 year ago)
A couple of diagnostic scraps: 
1: After it appeared that my first guess (that I had an incomplete copy of the viewer files cached that I needed a fresh copy of) appeared to not resolve the problem I wondered if perhaps I'd changed something in the F12 dev tools on a previous session and that setting had persisted, so I went in search of a way to reset all of that panel's settings to default.

I don't remember changing anything there but the browser did auto open the Debugger tab in the F12 tools several times stating that the link in Line 2 could not be found and I believe that what was highlighted was the location of one of the viewer files which I assumed to be in local HTML5 storage.

Unfortunately I did not copy or screenshot this information while I was still experiencing the bug, nor do I know how to reproduce it again now (a good thing I suppose).
NateLawrence (Over 1 year ago)
2) While I was experiencing this bug, the Preview's homepage never appeared to acknowledge that I had previously skipped the intro video between normal refreshes or 'Back' navigations (meaning within one chunk of navigations without any cache flushes, hard page refreshes, etc.) meaning that something appeared to me to have gone wrong with the site's cookies for the desktop user account I was using for IE11 as I could not seem to force a re-download of the viewer files nor could I get the homepage to load straight to the highlighted synth list after I'd skipped the intro video once.

In either case the behavior was unexpected and seemed to persist across navigation + closing + opening the browser, regardless of whether I attempted to reload the entire site fresh or not. (Granted, the intro video playing on the homepage is exactly what to expect after a cache flush or hard refresh.)

I don't know if this will be worthwhile to your testers, but thought you should know.
NateLawrence (Over 1 year ago)
3: One other symptom that I experienced intermittently during the error was that there would be a slice of whitespace at the top of the page with what appeared to be an unstyled horizontal rule running through the center of it.

This appeared in the exact same space that the Menu Bar toolbar appears when enabled and when I did try enabling it, it would load and function in a Private Mode window but not in a default window.
PhotosynthTeam (Over 1 year ago)
Thanks for this report Nate. You've given us a lot of info here. Hopefully it'll give our guys something to go on. Do you still have access to this computer?
NateLawrence (Over 1 year ago)
I do indeed. How can I help?
PhotosynthTeam (Over 1 year ago)
The fact that it worked fine in Private mode, and that flushing the cache didn't improve it in non-private mode makes us think that you may have discovered a unhealthy (and untested) combination of options on the 42 menu. (That menu stores its state in application storage which apparently does not get wiped with a cache clearing, and does not get accessed when in private mode.  So -- here's the key question: did you interact with the 42 menu on that machine?
NateLawrence (Over 1 year ago)
It's entirely possible, since I usually do use the panel, but I wasn't getting auto complete on any Preview URL, leading me to believe that any time I had used the Preview on that laptop before was only in Private mode, since even after I later flushed the cache, I kept the history intact.

I neglected to mention it above, but I actually did try to follow the viewer reset instructions from your post that announced the viewer update.

I went to the page and afterward copied and pasted the javascript instruction and pasted it into the address bar while on that page. I didn't see any change and didn't know if I'd done the right thing so tried again, going to the viewer reset page and appending the javascript bit to the end of the URL (it felt like that was not what the instructions said, but I tried it anyway).
NateLawrence (Over 1 year ago)
Neither seemed to have effect, so at that point I moved on to investigating add-ons, since it seems that many extensions/add-ons are not run in a private/incognito window and thus if that had been the interference, might have explained why it was still working there.

To be clear, since I eventually disabled all add-ons to no avail, I no longer believe that to be a possible cause.


Regarding the storage used, I looked in Internet Options > [General] > Browsing History > [Settings] and looked under [Caches and Databases] but didn't see anything listed from you and also browsed the directory for Temporary Internet Files, but there were so many that I didn't care to just remove everything there until I had no other choice.

All of this was before I did anything with turning the Guest account on.
NateLawrence (Over 1 year ago)
I implied it above and it may be obvious to you, but to be clear - in the error state the 42 menu would never appear. 

I know that you're suggesting that the lack of viewer was due to a prior combination of settings in the panel, but there wasn't any sign of any WebGL-driven portion of the viewer. I'm not sure what has to load for the panel to display, but there was no sign of it during this episode.

There was no loading % text, no sign of any form of photo, and the fullscreen icon had no effect when clicked.

I don't recall whether the Play / Pause or Fullscreen icons toggled when clicked or not.