Forum : Technical Preview

Get all your questions answered about our latest Photosynth Technical Preview.


Topic: Thumbnail regeneration hick-up?

Report Abuse Report Abuse
Last night I created http://photosynth.net/preview/view/9db987f0-182d-49d1-bffd-1285739b14d6?startat=15
I have changed the starting point, but this morning there is still no change of the thumbnail.
NateLawrence (9 months ago)
Hi, Joscelin, I'm not sure what all is going on here, but I notice that you are using a Share link that tells the synth to load at image 15.

If you load the synth without the "?startat=15" on the end like this: 
http://photosynth.net/preview/view/9db987f0-182d-49d1-bffd-1285739b14d6

then the image that the synth loads on is actually this: 
http://photosynth.net/preview/view/9db987f0-182d-49d1-bffd-1285739b14d6?startat=0
I got this by hitting [C] to jump into global camera as soon as the synth loaded to stop animation (also loaded the Map to make sure that I didn't move over a photo) then switched back to the normal camera view, left the synth paused on that beginning shot, and generated a new 'Share' link which yielded starting on image 0.

When I go to your profile + look at this synth's thumbnail (currently found at http://photosynth.net/preview/users/Joscelin.Trouwborst#4,9db987f0-182d-49d1-bffd-1285739b14d6 ) I see that same starting image + rotation leftward.
NateLawrence (9 months ago)
You can also verify which image the synth is currently set to start on by viewing the embed page without the delayload flag attached to the end of the URL (or explicitly set to false) or the autoplay flag explicitly set to false.

Vanilla embed: 
http://photosynth.net/preview/embed/9db987f0-182d-49d1-bffd-1285739b14d6

Embedded synth loads on page load, but autoplay is switched off: 
http://photosynth.net/preview/embed/9db987f0-182d-49d1-bffd-1285739b14d6?delayload=false&autoplay=false

Come to think of it, these same flags can be set on the synth's view page: 
http://photosynth.net/preview/view/9db987f0-182d-49d1-bffd-1285739b14d6?delayload=false&autoplay=false

In any case, the video thumbnail that I see on your profile page does match that beginning shot. 
It moves left immediately and when it does move back to the right, the furthest right that it goes is that exact shot of the palm trees framing the fountain.
Thanks Nate for giving it your attention. Maybe I have messed up somehow. I have set the starting image again. I have never paid attention to url peculiars. I find the explanation about them useful.
NateLawrence (9 months ago)
No worries.

If all you want is your synth's view link, just copy what's in your web browser's address bar when you're viewing your synth and don't bother using the 'Share' button. 
If you want to link to the image that you're currently paused on, then use the 'Share' button to get a 'Share link'.

To change to the embed link, just change the word 'view' in a synth's view URL to 'embed'.

Whenever you copy the embed code for a synth, you'll notice that there are some switches: 
'delayload' can be set to either 'true' or 'false' and controls whether the synth will load with the rest of the page or wait until it is clicked. 
The default value for embed links is 'true' + 'false' for view links if not specified.

'autoplay' can also be set to either 'true' or 'false' and controls whether the synth will immediately start playing as soon as the synth loads (whether it loads with the page or needs to be clicked before loading). The default value is 'true' if not specified.
NateLawrence (9 months ago)
In Photosynth 1's embed code, 'autoplay' is called 'slideShowPlaying'.

You can also specify width and height of the embed.

Here are a couple of older discussions that detail Share Links and Embed code for the Photosynth 1 site: 
Share Links: http://photosynth.net/discussion.aspx?cat=01b6f15f-42eb-49cb-a221-ed56615e1c47&dis=93a545a0-de2d-471a-9c42-bfea49b30714
Embed Code: http://photosynth.net/discussion.aspx?cat=01b6f15f-42eb-49cb-a221-ed56615e1c47&dis=b2b2e1d6-0692-4e58-bfdd-f13fb8808562

Note that Share Links in Photosynth 1 were much more detailed (resulting in much longer URLs) and that in Photosynth 2, the only camera variable included in Share Links is which image to load on (rather than including zoom level, etc.). 

More comments on that here from before the March update added the limited Share Links we have today to the Tech Preview: 
http://photosynth.net/discussion.aspx?cat=00581351-82d8-438d-a37b-7eadb3fb4991&dis=0fa98b75-21fc-4a43-a32a-d1d9cee97b37
I have seen an update of the thumbnail, so I must have messed up somewhere ;-). Thanks again Nate.
NateLawrence (9 months ago)
Glad all is well, in this case. ^_^
You need to be Signed In to add a comment. (Are you new? Sign Up for a free account.)