Forum : Technical Preview

Get all your questions answered about our latest Photosynth Technical Preview.

Topic: Desktop APP Password Problem

Report Abuse Report Abuse
JohnEarp (Over 1 year ago)
The Desktop application will not log me in with my Live ID and password.  I have reset the password and it still will not work.
Nathanael (Over 1 year ago)
Hi, John, by any chance have you set up 2 factor authentication on your Microsoft Account/Windows Live ID?

If so, you may need to create an app-specific password to use with Photosynth's desktop application.

Here are two reports by different people who had set up 2 factor authentication and were able to log into Photosynth's desktop application afterward. The first created an app specific password for his Microsoft Account and the second person simply turned off 2 factor authentication on theirs.
Example 1: (tobiefysh)
Example 2: (Gabreality)
bobbyyarsulik (Over 1 year ago)
This is a really late post but for me, even creating an app password did NOT solve the problem.

This is what solved my problem.

1. Use Internet Explorer.

2. Go to the settings.

3. Go to the advanced Tab.

4. Scroll down to the check marks under "Security"

5. Uncheck both, "Check for publisher's certificate revocation" as well as "Check server for certificate revocation".

6. Close the app login window, and re-open.

7. Login with your account, and it should open right up.

This worked for me, but I also disabled the 2-Step certification. It didn't work at first after disabling that, but after unchecking those settings, it worked just fine.
shoffmeister (Over 1 year ago)
I can confirm that the steps in the posting above work around the problem (which I also experienced).

Frankly, it is unacceptable to have to turn off checking for revocation of security certificates - i.e. to change a default Windows (Internet Explorer) security setting.

This does not help in getting the product out to interested customers.
NateLawrence (Over 1 year ago)
@shoffmeister, I'm only your fellow user and I agree with you that such changes to Internet Explorer security defaults should not be necessary.

I'm not in any way saying that you did not experience the login problem, however I have been using Photosynth since 2008 August 23 on many different computers with multiple accounts and I have never ever had to any such modification to Internet Explorer security settings, for whatever it is worth.

That is to say - in my experience the vast vast majority of users will never need to make the change that you refer to and bobbyyarsulik describes.
NateLawrence (Over 1 year ago)
Is there any other additional information that you can provide which might factor into what is triggering this behavior such as the region setting attached to your Microsoft Account, the version of Windows you are using (I'm interested to know if it is an international/non-US version), whether you are using any sort of proxy on your Internet connection, etc.?

Ultimately, all we can do as users is let Microsoft know that there is a problem, try to track down what the cause is, and hope that someone at Microsoft cares enough about their users to fix the problem.
shoffmeister (10 months ago)
@NateLawrence - my irritation by no means was directed at you ;)

Somehow the problem seems to have fixed itself for me. I have no idea why as (after a reinstall) my IE properly checks for revocations. I can only assume that server-side some SSL certificate was updated.
NateLawrence (10 months ago)
Glad to hear that all is well for you now. 
I wonder if things are different for bobbyyarsulik these days.

Something that interests me is what explanation there could be for users like myself not needing to change IE's security settings at the time that he and you originally reported the problem/solution.

I don't know if something installed on both of your systems could have changed something which led to that behavior or whether a server-side cert might have affected only those in a particular geography when pulling from local Azure servers on the CDN or something else we haven't thought of.
You need to be Signed In to add a comment. (Are you new? Sign Up for a free account.)