Topic: Export Point Cloud to 3d

Report Abuse Report Abuse
kmassey (Over 1 year ago)
I am a 3d modeler and I wish to find a way to export point clouds generated in Photoshynth to where I can open them up in 3ds Max. The Australian Center for Visual Technology offers a supposed program called VideoTrace in which you can generate a 3d model from a video or image sequence derived from point clouds, but I have not been able to get them to right me back. Does anyone know how to export the point clouds generated in Photosynth?
kmassey (Over 1 year ago)
Spell blunder: I wrote "right me back" instead of "write me back". I beg your forgiveness!
dariusmonsef (Over 1 year ago)
Know problem about the spelling mistake ;)

You may want to check out this post:

Has some info about how some other smart people are playing with the point cloud... and has a link to some work done to extract the point cloud.

fenderly (Over 1 year ago)
yeah, bu how can one download the point cloud as a file
fenderly (Over 1 year ago)
*but, not bu
NateLawrence (Over 1 year ago)
Fenderly, you've got several options since Binary Millenium's manual harvesting techniques were published in 2008.

Christoph Hausner wrote a very handy and easy to use app that will allow you to choose which point clouds you want to download from a synth:

Kean Walmsley wrote a Photosynth point cloud import plugin for AutoCAD 2011:

Henri Astre advanced Christoph's work in his own PhotosynthToolkit (which also formats Photosynth output for use with Yasutaka Furukawa's dense reconstruction tool PMVS2 and gives you the option of also downloading the full resolution photos from a synth)

MeshLab 1.3.0 introduced a built-in plugin that imports Photosynth images and point clouds.

If you simply want to save the primary point cloud as a single file, SynthExport is the simplest and it also saves in a number of formats.

Hope that helps!
brakar (Over 1 year ago)
I have had problems with downloading photosynths the few last days. I first noticed the problem trying to download a synth using Henri Astres Photosynth toolkit6. Then I discovered there was a newer version (7), tried that one, but still negative. The exporter has worked flawless before, and I have tried on different PC's, so I suspect the problem might be on the PhotoSynth server side.

I also tried the import function in MeshLab after reading your last post, (thanks for the tip!), and receives the following error message: 
"The web service returned an error"
Nathanael (Over 1 year ago)
Jorn, I don't understand why you and I are getting different results. In the past hour, I successfully redownloaded my point cloud from my faithful old hydrant synth ( ) with SynthExport, PhotosynthToolkit, and MeshLab.

Try using my synth with the exporters, just to make sure it isn't an issue with a specific synth (I'd be glad to test ones that you've been having troubles downloading).

Your theory about the Photosynth webservice having been updated (and therefor breaking the downloading apps that talk to it) is plausible as the same thing occured when panorama support was added just over a year ago (see this discussion: ) and I know that we are on the verge of mobile panorama support being added this year.

Test Results:

I remain unable to reproduce any download errors, though.
brakar (Over 1 year ago)
I just tried to download your hydrant and a few other synts, among others: by using both PhotosynthToolkit 6 and 7, and Meshlab 1.3. Still same result. In the PhotosyntToolkits destinatinfolder for the download, there is a logfile with content (translated into english):
"Host not recognized"
"Error while downloading Soap request"

Good news is I discowered dowload works fine in Christoph Hausner's exporter.
Nathanael (Over 1 year ago)
Glad to hear SynthExport is working for you.

I am curious: when you use PhotosynthToolkit, are you using a single word (no spaces) for the destination folder's name? I have noticed in the past that using a space anywhere in the destination folder's filepath results in strange errors and failure, but perhaps this is not the same problem you are facing.

Also, in Meshlab, do you leave the checkbox to download the photos checked? Have you also tried unchecking it?
brakar (Over 1 year ago)
Yes, with the PhotosynthToolkit I was using single word path names.

After reinstalling Meshlab, I have had it working on my Win7 64bit laptop. So, I am beginning to think the cause of my problems must be on this side.