Forum : Bugs

Did the leaves fall off? Something not working right? Let us know how we can improve the Photosynth experience.


Topic: Cannot view PhotoSynth - Win7 x64, IE9, Silverlight 4 (4.0.51204.0)

Report Abuse Report Abuse
chrismtodd (Over 1 year ago)
I cannot see photosynth on Win7 x64, IE9, Silverlight 4 (4.0.51204.0)
All I get is a black box.
I can view in Direct3d Viewer option.
Nathanael (Over 1 year ago)
This is likely because you are using the 64bit version of IE9 and Silverlight 4 only comes in 32bit. 

Silverlight 5 will come in both 64bit and 32bit but will not launch until fall of 2011.

The short term fix for you is to use the 32bit version of IE9. You don't need to install anything extra or uninstall anything. When you install IE on a 64bit version of Windows, it installs both a 64bit and 32bit version of IE.
chrismtodd (Over 1 year ago)
Definitely using 32bit IE. Silverlight actually loads, I can right click on the black square that is silverlight. Just get a black screen and no photosynth.
Nathanael (Over 1 year ago)
Hmm. Strange. I'm using the same list of software and it works on my laptop. 

I have seen the behaviour you describe before, but I forget which browser and computer I was using at the time.

...I just tried every combination of Browser Mode and Document Mode in IE9 (F12) and am currently unable to reproduce the error, but will post back if I can figure out what triggers it.

Do you have any other browsers installed and do they behave in a similar fashion?
chrismtodd (Over 1 year ago)
No other browsers installed.
oosterwal (Over 1 year ago)
I have the same problem on Windows XP SP3, IE7, Silverlight 4.  I've tried it on two different systems using both IE7 and the latest release of Firefox (4?).  All the photosynths and panoramas come up with a black screen.  I can right click on the silverlight window and open up the silverlight settings.
adrian.info (Over 1 year ago)
Hi oosterwal,

Could you try it on a different network? maybe it's a proxy issue.
mcpata2002 (Over 1 year ago)
Over 1 year, still no answer... Win7-64 with 32 bits IE9. When I "edit" the synth it rocks, but not in the "view" state. Rocks with Firefox and Chrome, thus not a proxy / network problem. Okay, Safari didn't work as well, that's good.
Nathanael (Over 1 year ago)
McPata2002, It's very strange that the editor would work for you but not the viewer as they're the same exact sort of file: a .XAP

In IE9, could you please: 
1) navigate to a view page, 
2) hold the [Ctrl] key and then tap the [F5] key while holding [Ctrl] 
(to try to do a hard refresh of the view page and all associated files, including the viewer app)

Thanks.

Another way to do this, would be to clear IE9's cache (probably called "temporary internet files"). Don't clear your cookies or history - just your cache.
solimv (Over 1 year ago)
I had the same problem (Win Vista, IE9, Silverlight 4/5). I solved it by adding "photosynt.net" as trusted site in IE. (tools > internet options > security > trusted sites > button "sites" > write "photosynth.net"
biggoomba (Over 1 year ago)
I realize this is an old post but I struggled with this problem forever so I would add a little bit that I found out today.
 
If the silverlight control has 'windowless mode turned on 
 
It will just show a blank page in IE9 on SOME computers. In windows 7, if you minimise the IE9 and then hover over the icon on the task bar, you can see the page as it should render in the little preview box.
 
It must be a problem with certain graphics accelerators\drivers and IE9. If you go to the advanced options on Internet Explorer and check the box for 'Use Software Rendering instead of GPU rendering', there is a good chance that the page will display correctly.
 
So, either remove the windowless parameter from the silverlight app OR Use Software Rendering instead of GPU rendering
You need to be Signed In to add a comment. (Are you new? Sign Up for a free account.)