Topic: publishing locked up

Report Abuse Report Abuse
captain_jay_davies (Over 1 year ago)
the progress bar is stuck at Publishing synth (89% synthy)  Should I retry creating over again or wait how long to see if it eventually completes?
dariusmonsef (Over 1 year ago)
How long has it been stuck on that message?
captain_jay_davies (Over 1 year ago)
at least 30 minutes.  I tried 2 more times with the same results.  It goes through all the processing but when it reaches publishing the progress bar moves within a few seconds to about 80% done and then stops.  I am using Vista, have a gigabyte of ram, on wireless with a cable based broadband, 9 photos totaling about 1.7MB.  No activity shows up on my account and nothing appears in recent synths.  I think I will uninstall and reinstall before trying again.  This all occurred around 10 pm CST USA yesterday and did not find any suggestion of website problems during that time. Also, other new synths were still appearing, also suggesting no website problems.
Could there be anything else that I may be overlooking?
Fere (Over 1 year ago)
I have waited 6 hours on publishing, in the hope it'll work in the end but unfortunatelly it didn't so I aborted process though it took another 6 hourts to precess the 700 photos.

Did the fact that I loged in on Photosynt from another PC on the same account meanwhyle has affected the publishing stage?

I've got to mention that I have really good internet connection.
TonyErnst (Over 1 year ago)
We here at photosynth believe we corrected the problem that was causing this issue.  Is anyone out there still encountering it?
jdunn001 (Over 1 year ago)
I think I might be encountering this issue.  The status has been, "Publishing synth (100% synthy)" for about thirty minutes.  There are forty photographs and I'm on a cable broadband connection.  Do I just need to give it more time?
jdunn001 (Over 1 year ago)
same status, quitting now.  i'll try again tomorrow.
caroleb56 (Over 1 year ago)
I've got the same problem 12.00AM -5 eastern time-14/02/2009 -tried 3 times, 30 min. each time result: 0.0GB used of 20.0GB ??? Publishing synth(63%)for 5 pictures- no noncence result???? Using XP and internet explorer 7
thank you
Fred_Oxford (Over 1 year ago)
Cardinal had the same problem last night - seems to be hanging on the "publishing" step
poltergeist313 (Over 1 year ago)
dont know why that happens. guys, try compressing your file!
maybe your pictures are really big. try to resize it. make it a little smaller.
chop-up those extra bytes.
It might help the synth server to publish it more quickly.
poltergeist313 (Over 1 year ago)
to jdunn001.   try resizing you pics. most cameras has a large megapixel. if you're only uploading 40 pictures it should be less.
I tried it first with only 7 pictures and it only took me 3 minutes.
Maybe its because I resize my picture and no pics of mine are larger than 600 kb.

I just tried it to see if this synth really works. and thankfully it WORKS.

I dont have any idea yet what to synth thats why i just put any pictures I like.
jdunn001 (Over 1 year ago)
Size does matter.  I resized the photos to 1024x768 then published in a couple minutes.
dariusmonsef (Over 1 year ago)
My guess, and somebody else can probably give you a better answer...

Is that the synth got stuck on the first try and those images are stuck in the Photosynth system somewhere.  We have a check in place to save you time and effort when re-synthing something and don't re-upload images that are already in the system... so the bug seems to be that those images are stuck and causing things to die... but the synther isn't re-uploading them. (I think this is a known bug and something the guys are working on fixing.)

If you only resize the bigger images slightly, it might work because technically they are new images.
Fred_Oxford (Over 1 year ago)
Cardinal had a problem with a synth today - he uplaod the first version okay, then tried to remove some images and the system locked on publishing
Ross51 (Over 1 year ago)
Still seems to be locking at Publishing.. How long should it take with 60 pics???
Bert (Over 1 year ago)
Hi Ross, it depends on your connection, but the time should me measured in minutes.

Is the problem reproducible or intermittent?
Ash.Law (Over 1 year ago)
It seems this issue is re-occuring now. I'm on my third attempt now attempting 13 photos that are 1024x768, 100% synthy.
Progress bar is at about 4/5th's aross the screen, "Publishing synth"
IE8,Vista x64, 4GB RAM although it appears to be a server side issue.
thpdg (Over 1 year ago)
Mine is doing the same thing.
I wonder if we have to wait until Monday for someone to come into the office?
Ash.Law (Over 1 year ago)
My final attempt worked so it might just be a backlog or overload rather than the service barfing totally.
roger.clemens (Over 1 year ago)
I've been trying to upload synths all last night and today. Only a 3 photo test synth worked out. I'm trying it across two computers, one with the firewall turned off.  Vista and XP represented, latest upload program running.  They all get stuck on 'publishing synth' followed by the percentage of synthiness.  Wish it would start working!!!
richardst69 (Over 1 year ago)
hanging on 67% publishing  what is going on?
richardst69 (Over 1 year ago)
have restarted 3 times hangs at the same place
Bjorn.Dijkhuizen (Over 1 year ago)
I have the same problem, many times I create a new synth, it uploads fine, processes fine, then hangs on publishing for ever ... happens 80% of my tries.
dawidgatti (Over 1 year ago)
Same problem whit a 1st synt - stuck at 53% for more then 1h.
steffen3baer (Over 1 year ago)
hi...same problem (80% and it hang up).
Is their anyone hwo work on this issue to solve ???
could one of the guys say some words about the status ???

thx from germany...
dgjones (Over 1 year ago)
My synth hung up twice at night, Fri and Sat.  At 11pm it was at 30/44 and uploading.  When I got up it was stuck at 'publishing synth 98%'    Could it be computer can't handle all incoming synths? ?
Hope.101 (Over 1 year ago)
I am having the same isue. 10 pictures hanging on 45% publishing.
Hope.101 (Over 1 year ago)
I am going to attempt resizing my images and give it another go.
amcnerlin (Over 1 year ago)
I'm also having this issue - tried it twice now using a similar set of images.
dgjones (Over 1 year ago)
Tried sending a third time while at church.  The stoppage occurred at the same 98% point.  My feeling is that resizing won't fix it [ Hope 101] as this last synth was made from photos taken at a smaller no. of pixels.
Jake33 (Over 1 year ago)
worked before with same-sized pictures, but now it stops at Publishing Synth (89% synthy). I need this for a project, i've retried many times, still have the problem.

photosynth 2.109.415.1554
windows xp pro sp3
fast cable internet (service electric - PenTeleData)
sastay (Over 1 year ago)
Same problem here - great software, can't wait for a working version ;-)
Buddhabrot (Over 1 year ago)
same problem, xp sp2, photosynth 2.109.1554
Rockman87 (Over 1 year ago)
Size isn't the problem... it still freezes up when only using 40 photos... than if you close the program and resynth... sometimes it publishes sometimes it just sits there forever doing nothing.
Rockman87 (Over 1 year ago)
It seems to publish a greater percent of the time, since this issue has started, if you don't choose your thumbnail image.
RuiOliveira (Over 1 year ago)
Same problem. I Start using photosynth 3 days ago and my first attempt runs ok. After that is stopping during the publish fase. I already try 5 times...
aj0020020 (Over 1 year ago)
I've tried 3 times today. Stuck at Publishing for 2 Hours. It might be from the new update, I just installed it this morning.
Nathanael (Over 1 year ago)
Guys (and ladies),

Occasionally this crops up for a day or two (sometimes three if it happens over the weekend). I'm sure that the Photosynth team will have this whipped for us by the end of the week if not much sooner. Just hang tight for a day or so and everything should be cool again.

As others have said above, it's not due to the size of your photos or anything like that. The Photosynth servers are clearly just having a hard time this weekend and they'll be back soon.
sixthsynth (Over 1 year ago)
Same here, 2 synths, one 300+, one <100 photos; one w/ changed thumbnail, one not.  finished one 11pm PST last nite, one just a few minutes ago.  Go to explorer in Vista and entered "
%temp%\photosynther" (do not use quotes) and log shows: 

PSWebClient version 2.0.1519.16
Target: x86 OMP
Running on Windows 6.0.6001 Service Pack 1
Wow64: yes
Processor: architecture 9 family 6 model 23 stepping 7
Number of processors: 4
Memory available: physical 8190 MB virtual 4095 MB......  

14:03:54 VtApp: Collection completed (49% synthy), but isn't avialable for viewing yet.
14:03:54 VtApp: SUCCESS
aj0020020 (Over 1 year ago)
Thats weird.
aj0020020 (Over 1 year ago)
Synth 18 : 2 images, 10 points
  0: 43 (C:\Documents and Settings\Owner\My Documents\My Pictures\Brewers Game\DSC01737.JPG)
  1: 45 (C:\Documents and Settings\Owner\My Documents\My Pictures\Brewers Game\DSC01739.JPG)
Synth 19 : 2 images, 50 points
  0: 38 (C:\Documents and Settings\Owner\My Documents\My Pictures\Brewers Game\DSC01732.JPG)
  1: 42 (C:\Documents and Settings\Owner\My Documents\My Pictures\Brewers Game\DSC01736.JPG)
13:24:02 VtApp: CollectionUploader: UploadFile:End failed hr(0x80072EFF), retry 0
13:24:13 VtApp: Collection creation time: 108.7
13:24:50 VtA
aj0020020 (Over 1 year ago)
Does anyone have logs from before this problem
aj0020020 (Over 1 year ago)
If you go to one of the links, it cant find the file.
aj0020020 (Over 1 year ago)
I have one that will be done in 17 minutes.
Let's see how it goes.
sastay (Over 1 year ago)
Nathaneal wrote: "... The Photosynth servers are clearly just having a hard time this weekend ..."

@Microsoft team: Take this as a compliment - you've created some amazing tool for us - it's worth waiting for it a while ...
dgjones (Over 1 year ago)
11pm Sun  The fourth attempt was successful, and completed in 10 minutes or so.  I couldn't believe it, almost as if the other photos were still visible to the photosyth computer.
Scott (Over 1 year ago)
Hi everyone - we've found and fixed a server problem that we think is at the root of these publishing delays.  Check out the thread here:
Nathanael (Over 1 year ago)
Regarding the .dzi files above, you can view them if you copy the address and paste them into the form on this page:
zaxxon82 (Over 1 year ago)
I am having problems with the program hanging while publishing.  Is this what I can expect or is this going to be fixed?

darwink2x (Over 1 year ago)
I am also having this problem. It started up today for me.
sarahgayle (Over 1 year ago)
Having the same issue, 58% complete - 2+ hours.
AlanCole (Over 1 year ago)
Ditto on 6/21/2011.  Just found out about Synth.  Went from stalled full-size JPGs to stalled 664x1000px JPGs at <500KB each.  The small versions have different filenames so the cached names won;t be an issue.  Only attempting 15 files for a total of 6MB over a 2Mbps upload link.  Hung at "Uploading file 2 of 17 (100% synthy) 0 minutes remai..."

Question: 17 files uploading; that's 15 images, one thumbnail plus what else?
AlanCole (Over 1 year ago)
Never mind; they went after 30 minutes or so.
Nathanael (Over 1 year ago)
Okay. Here's a bit of info: 

zaxxon82, darwink2x, and saragayle were having problems because the Photosynth servers were having troubles the week of 2011 May 3. More details here:

For Alan, to the best of my knowledge, that same problem is not occuring today.

A few notes:

1: The link that I list is outdated. The current page is here:
Nathanael (Over 1 year ago)
2: The size of the images is not the issue. Neither is their filenames. Before Photosynth uploads an image to the servers, it converts it to the Deep Zoom Image format and creates a hash for the image. The hash ( ) is an alphanumeric code created from the metadata in the header of the file plus the actual content of the file (pixels). To change the hash, all you have to do is change the metadata (example: add or change the 'Author' field of your photos' metadata), so it doesn't matter if the filename is the same or not. Neither do you have to degrade the quality of your photos by downsizing them. (In fact, the higher the resolution of the photos, the better: .)
Nathanael (Over 1 year ago)
3: To answer your question about what the other two files are, in addition to the photos, they are collection.dzcz (the deep zoom collection for the synth's 2D view) and collection.synth.bin (contains the thumbnail, automatically computed geotag (if your photos had their own geotags to begin with), and other synth metadata.

You can view these files for yourself, between the time that the synther completes scene reconstruction and finishes uploading all the files to the Photosynth server by typing the following into the 'Run' command of Windows (or any 'My Computer' or 'Windows Explorer' (not Internet Explorer, mind you): 
Nathanael (Over 1 year ago)
Inside of the 'photosynther' folder, you will also find log files for each of your synths and an 'images' folder that contains the deep zoom images for your current synth all zipped up with the extension of .dziz. If you're feeling adventurous, you can copy (not move, mind you) these .dziz files out of this folder, rename their extension to .zip, and either decompress each deep zoom image into its own directory or just browse the zip in place with Windows Explorer.

You'll find that the Deep Zoom Collection (and I believe the collection.synth.bin file as well, though it's been a while) are zipped as well, if you feel like taking a peek inside of them.
Nathanael (Over 1 year ago)
Remember that the images, collection.dzcz, and collection.synth.bin files will all be deleted from your hard drive after all files have been verified to be on the website (that 'verifying' is the actual 'Publishing' phase which usually takes less than a minute and comes after all files have been uploaded). 

That being the case, the time that these synth files are actually available can actually be pretty short, so if my aim is to actually make a copy of them, I will sometimes disconnect my internet connection after the 'Generating image tiles' phase is complete (because that means that the synther is finished asking the website whether each image is already in the database, so there is no need to be connected during feature extraction, image matching, or scene reconstruction (besides uploading the images, that is). That will give you control over when those files will be deleted from your hard drive, because they need to upload first.
dirtayg (Over 1 year ago)
it keeps doing it to me, stuck on publishing synth
As of today 7/28, we've got a new upload problem that affects people uploading to Photosynth or Bing Maps.  Hopefully it will be resolved in a few hours. I'll update this thread. Sorry about this.

David and the Photosynth team