Topic: Can't edit my synths?

Report Abuse Report Abuse
ikjoyce (Over 1 year ago)

I get the following error whenever I try to edit my synths: 

An unknown error occurred:Error 0x1A88.  Debugging resource strings are unavailable. See 
   at Microsoft.Maps.MapControl.Map.LogResponse(Object sender, DownloadStringCompletedEventArgs e)
   at System.Net.WebClient.OnDownloadStringCompleted(DownloadStringCompletedEventArgs e)
   at System.Net.WebClient.DownloadStringOperationCompleted(Object arg)

I have tried in Chrome and IE9. Same issue in both?

ikjoyce (Over 1 year ago)
Hmm... I also seem to have a problem with the Direct3D viewer - if I click to use it, I get the install page for Photosynth, but I already have it installed. I have tried uninstalling and re-installing it, but the same issue. 

Is there something I am missing?
Nathanael (Over 1 year ago)
ikjoyce, I can't say that I've ever seen the editor error that you are experiencing, so I can't really help with that. 

Out of curiosity, what version of Silverlight do you have installed? You can check easily by right-clicking on a Silverlight control and clicking the 'Silverlight' menu or by visiting


Regarding the Direct3D viewer, what web browser are you attempting to use and what operating system are you using?

The Direct3D Photosynth viewer only works in 32bit Internet Explorer and Firefox 3 on Windows xp through Windows 7. If you have a 64bit version of Windows then you already have both a 64bit and a 32bit version of Internet Explorer. Be sure that you are using the 32bit version.

Also, be sure that if you're using Internet Explorer, your Photosynth add-on is enabled in the add-on menu. 
(Gear|'Tools' -> 'Manage add-ons' -> 'All add-ons' -> 'Photosynth Class' -> Enabled)
ikjoyce (Over 1 year ago)
Thanks Nathanael. 

I am running a 64-bit version of Windows 7, and have tried Chrome and IE-9 (32 bit) with the same results. I'll check the version of Silverlight, and also make sure the add-on is enabled in IE.  Failing that, I'll try Firefox! 

Annoyingly, I am on my work computer at the moment which IT have locked down tighter than something unmentionably tight, so I can't try anything until I get home later. I'll let you know how I get on!

ikjoyce (Over 1 year ago)
Ok, so I checked, and everything is turned on, as it should be. I now find that I can use the Direct3D viewer in IE9, sort of use it in Firefox (it is a bit temperamental), and not at all in Chrome.

On all three browsers, however, I still cannot edit my synths and get the same error message.
Nathanael (Over 1 year ago)
Yeah, Firefox 4 broke the Photsynth Direct3D viewer in Firefox when they changed their Direct3D implementation and FF5, FF6, and FF7 have done nothing to fix it. You can get a download of Firefox 3 from the Firefox website: in which the D3D viewer works as intended.

I'll try to get someone from the Photosynth team to chime in on the editor. 

Part of me wants you to try clearing your cache. Since you have the same error message in multiple browsers, though, it makes me wonder if the problem is in Silverlight's own local application storage (although I didn't think that the Photosynth viewer used that feature of Silverlight).

One thing you could try is to install the Silverlight 5 preview here: 
That's what I'm using on my machines.
ikjoyce (Over 1 year ago)
Tried Silverlight 5, and it didn't work at all. So, I uninstalled, and re-installed Silverlight 4. Lo and behold, I can now edit synths! :o) 

Thanks for all your help! Off to sort out my first attempt - the Cliffs of Moher!
Nathanael (Over 1 year ago)
Ha... that's the craziest thing. ツ I've been running Silverlight 5 beta since December of last year with pretty much no problems that entire time.

In any case, I'm glad you're up and running.