Topic: downloading

Report Abuse Report Abuse
Prusey (Over 1 year ago)
Seem to be having problems downloading this program - stops normally at 65%!!
Any suggestions.   Thanks in advance and hope to chat to all when I have this sorted.   Prusey
NateLawrence (Over 1 year ago)
Prusey, I'm not sure if you'll see this or if you're still having problems, but here is a direct link to the installer. Try right-clicking on it and saving.
Russell_G (Over 1 year ago)
Hello, I am able to download the .exe file, but once I open the .exe file and click run I get "C:\...\photosynthinstall.exe is not a valid Win32 application". Is there anything I can do to get around this?
Nathanael (Over 1 year ago)
Russell_G, that sounds like an incomplete download of the installer. Try clearing your browser's cache and downloading again or downloading with a different browser.

When I look at the installer I used earlier today in Windows Explorer (My Computer) in Windows 7, the filesize is listed as 11,217KB. Your copy should match this.
Russell_G (Over 1 year ago)
Nathanael, I tried both routes. I cleared my I.E. browser's cache and tried again with I.E. and failed. Then I downloaded Google Chrome, downloaded & it failed with the same message as before. Also everytime I the .exe file is 11,217KB, so I am getting the full download. Any other suggestions?
Russell_G (Over 1 year ago)
Wow, I really had some quality grammar in the statement above. That should read, "Also, everytime I download the .exe file, the filesize is 11,217KB,".
Nathanael (Over 1 year ago)
=) We're all in the same boat, grammatically. I have often wished for an [Edit] button on these forums.

According to what I'm hearing on this other discussion ( ), it sounds like some of Photosynth's servers may have an incomplete copy of the installer. Your report of the filesize is different than what I'm hearing there, though.

Try downloading and running they copy of it that I placed on my Skydrive account and tell me if it's any different for you.
Russell_G (Over 1 year ago)
Bummer, still didn't work after downloading from your Skydrive account. 

Okay just to sum up, maybe this will spark something,
I am using windows xp, the file I am downloading is 11,217KB, when I try to run the .exe file I get the Win32 application is not valid, ...oh and I am on a AT&T wifi mifi hotspot deal (this could be part of the problem). It is really fast, but I don't know. Let me know what you think.
Nathanael (Over 1 year ago)
When you're quoting the filesize to me, are you getting the size from your browser's download window or from Windows Explorer when you're looking at the download folder in 'Details' view?

Before posting the link to the copy on my Skydrive account, I did redownload it from myself and run it to verify that it executes correctly, so I just don't know whether it's a case of an incomplete download or something else like a missing Windows component, but I still suspect an incomplete download.

Sorry, I'm sure that this is frustrating for you. If anyone else has any suggestions as to what is going wrong, I'd welcome your help.
Russell_G (Over 1 year ago)
The 11,217KB is from the windows detail view.
Russell_G (Over 1 year ago)
One thing to note is that the first time I downloaded the file it took 10 mins, then the following times I tried it took less than a minute. I had someone else here in my office download it and it was going to take 10 mins as well. I don't know if this has something to do with it, but I thought I would share.
Due to the great sleuthing work of our friend Nathanael, we have found that the installer appears to be broken for everyone running Windows XP. (Works for people on Windows 7). We're working to understand how this could have happened. 

Our apologies for this. Hoping to have a fix tomorrow.

David Gedye
Principal Program Manager, Photosynth
GaryMortimer (Over 1 year ago)
Ah ha!! I am having exactly the same issue Russell, don't feel alone we should light candles and start a support group!! Could a previous version be put up for XP?? Well done Nathanael.
VsKbPhotos (Over 1 year ago)
Window 7 user here and the download has never been faster!
GaryMortimer (Over 1 year ago)
Humm, nothing happened so perhaps Photosynth no longer supports XP, bummer.
Nathanael (Over 1 year ago)
Gary, David said they were working on it. Give the team a chance to work on it and allow David a chance to reply before you suddenly conclude that Photosynth has discontinued support for Windows xp.

I know that it's been a couple of frustrating days for you, but they found out what the problem was not 24 hours ago. Even when they have a revised copy of the installer ready, it will probably take a few hours for LimeLight Networks to cache the new copy of the installer across all of their servers worldwide.

In the meantime, Mike McSharry has provided an older copy of the Photosynth app installer that should work on Windows xp here:

Steady on. I'm sure we'll get an answer before a week has gone by.
We've rebuilt, re-signed, retested, and redeployed our installers. They should work fine in Windows 7, Vista, and XP now. Direct link to the installer is

Please let us know if you see any further problems.
David and the Photosynth team.
GaryMortimer (Over 1 year ago)
That worked, thanks David I shall now get on and synth my cats. Seriously though the Japan disaster underlines for me an important use for photosynth in the future, the mapping of tonnes and tonnes of debris. Anyhow off topic, excellent support for a free to me product. Thanks.
Russell_G (Over 1 year ago)
Wow, great job guys. I got it working. Thank you. I look forward to submitting my first photosynth by the end of the week.
michaelpr (Over 1 year ago)
Hi, I get an error when trying to install photosynth. I created a new topic before I saw this one. Please have a look there.
haoala (Over 1 year ago)
Thank you for the fix. It works, I'm glad to be able to create synths now.
Aerodigitales (Over 1 year ago)
hello you all. I'm new here and need help. My photosynth is at 61% and doesn't go anywhere... how can I know what is missing or what is wrong with it? I appreciate your answer. Thanks!
Nathanael (Over 1 year ago)
Hello, Aerodigitales, 

The issue you are dealing with is actually not related to this discussion. 

I took a look at your profile and saw this photosynth of yours:

I see that it is 61% synthy and I think that that is what you are talking about. 

What that means is that even though all of your photos were uploaded to the Photosynth website, Photosynth could only figure out how to match 61 percent of the photos to each other.

If you look at your synth in 2D View...
... you will see several groups or clusters of photos, showing which photos Photosynth was able to match together.

You can get shooting instructions of what Photosynth should be able to successfully match from the Photosynth Photography Guide available on this page:
Nathanael (Over 1 year ago)
I think that the main problem you are having is that you took photographs as though you were shooting a panorama, but then you uploaded them as a photosynth instead of a panorama. does host both photosynths and panoramas, however they are created with different tools.

To upload them as a stitched panorama, please download the free Microsoft ICE program from this link:
I tried your photos as a panorama in ICE here:

There are some big stitching errors visible on the edges of the windows and doorways. I believe that this is due to your cameras lens' moving positions between input shots. All panorama software will encourage you to keep your lens perfectly still if you want a perfect panorama (because panorama stitching is 2D stitching).
Nathanael (Over 1 year ago)
If you would like some more tips on how shooting a photosynth is different than shooting a panorama, I have a much longer explanation that links to other discussions here: