Forum : Bugs

Did the leaves fall off? Something not working right? Let us know how we can improve the Photosynth experience.

Topic: No Silverlight support for OS X Mavericks?

Report Abuse Report Abuse
tnproperty (Over 1 year ago)
After updating to this Mac OS I am unable to view any silverlight content including this site.  It doesn't work in any browser, but I'm using Safari.  I have read others having similar issues also.  Any ideas, suggestions or work arounds?  I have tried reinstalling Silverlight and changing plug in security to "Always Allow".  I know that now Safari "Sandboxes" all plug ins, and usually it asks if you want to enable (which it never asked for this site for some reason).  Thanks!
ATPeck (Over 1 year ago)
Sigh....this is why I don't do windows :)
bluebottle (Over 1 year ago)
Hi tnproperty, I was having the same issue as you after updating to Mavericks.
I came across the solution that worked for here - have a read through: Fixes/Fix_Silverlight_issues.htm#Enable Silverlight

1. Open in new Safari tab
2. In the top left of Desktop, next to Apple icon, click 'Safari'
3. Under Safari select 'Preferences'
4. Select Security
5. Click on the 'Manage Website Settings' button
6. Click on Silverlight in the list of available plug-ins on the left   
7. On the right, select the Photosynth website
8. Click 'Run in Unsafe Mode' (to give Silverlight unrestricted access to computer resources when running at the Photosynth website.
9. Beside 'When visiting Other sites'
Select 'Allow'. Or 'Allow Always' only if you intend for all websites to be allowed to use the selected plug-in.
Do not select 'Run in Unsafe Mode' 
10. Click Done. 
11. Quit Safari & then Reopen, and go to photosynth website
bluebottle (Over 1 year ago)
The link I posted isn't displaying properly and has left some of the address out.
I'll try post it again:

www. Fixes/Fix_Silverlight_issues.htm#Enable Silverlight
tnproperty (Over 1 year ago)
Excellent thank you so much!  I had looked at the above place in settings before, but the real trick is you have to be at the exact before you will see the options after "Manage Website Settings".  Any other page like  /explore and you will not be given the option for the plug in.  Many thanks to you for answering!
You need to be Signed In to add a comment. (Are you new? Sign Up for a free account.)