Topic: Sharing with Facebook doesn't work

Report Abuse Report Abuse
photosynthesized1 (Over 1 year ago)
Uploading to Facebook has never worked right for me in Photosynth. It has always given me an upload error. At one point if I clicked on "retry" it would open Facebook up and prompt me again and it would work.

Right now the behaviour is this:
1. Go through the "share" process in Photosynth.
2. Open up Facebook app. Shows message "you have already authorized Photosynth. Press "Okay" to continue"
3. I press Okay
4. Goes back to Photosynth with a popup: "Facebook login was either cancelled or encountered an error"
5. I click "close"
6. Nothing has been uploaded
7. I go back to "settings" in Photosynth. Facebook says "not connected".
8. If I click on "not connected". I get the same "you have already been authorized..." message.

GabrielChan (Over 1 year ago)
Hi photosynthesized1,

Something to try quickly to see if there are some Facebook app permissions problems:
1) In the Photosynth app, verify that you're in a "not connected" state for Facebook in the Settings tab.
2) Go to your Facebook Account Settings through and remove Photosynth app permissions ( Account Settings -> Apps -> Photosynth -> remove)
3) Open the Photosynth app and connect your Facebook account in the Settings page by tapping on the "not connected" text.  Follow the prompts making sure to authorize the app to access your Facebook account.
4) Try to Share your panorama through Facebook again.

Note, there have been a couple of cases where the initial authorization is unsuccessful and you see the error you received.  If that happens, try to connect again through the Settings page, or just by Sharing a panorama.

Gabriel - Photosynth
birdhombre (Over 1 year ago)
I get the same error with the exact same steps listed in the first post when using the iPhone app, and it's been going on since at least July 2011. I've tried removing the Facebook app and re-authorizing, but it gives me the same message. Posting to Facebook worked just fine back in May, so I'm not sure why it suddenly stopped working; I was hoping the latest version of the iPhone app would fix it. Incidentally, I can post to Facebook just fine from the Photosynth website.
birdhombre (Over 1 year ago)
Just an update: The version of the Photosynth iPhone app posted today seems to have fixed the problem. Finally! Hopefully it'll stay that way.