Forum : Bugs

Did the leaves fall off? Something not working right? Let us know how we can improve the Photosynth experience.


Topic: Large Synth Hanging?

Report Abuse Report Abuse
sir_ivar (Over 1 year ago)
Heya, I created a large synth from about 800 images.  According to my internet connection status the file has uploaded a little over 4 gig in the past day and a half.  The window has been stuck for a long time at "Uploading file 150 of 151 (99% synthy), experiencing ...".  I can't read the rest of the message but I'm guessing it's "network connection problems" or some such.  The full resolution images are only 3.6 gb in size.  Should I cancel the synth or just hope it finishes one of these days?

When I look for the loog files, I get this message, "'C:\Users\Mark\AppData\Local\Temp/photosynther' is not recognized as an internal or external comman, operable program or batch file."  I've searched all over the harddrive for the log file and can't find it.  Any suggestions?  I'm running Windows Vista Ulimate 64bit on a Dell Precision M4400. Intel Core2 Extreme CPU Q9300 @ 2.53Ghz and have 8 gigs of ram.

Thanks and love the potential of this software!
K (Over 1 year ago)
I can't diagnose your issue in detail from a distance but it does sound like something is stuck.  The good news is that the synther takes a hash of the image and checks to see if it's already been uploaded so if you try again the synther will skip those first 150 images.  I'd just cancel and start over.  I've seen a few people who have used the trick of creating smaller synths with maybe 100 images at a time and then creating the large synth at the end once all the individual images have already been uploaded.

Try this to find the log files:
- hit Win+R to open the run box (or find it in the start menu)
- type "%temp%\Photosynther" (no quotes)

That should take you to the log folder directly.
sir_ivar (Over 1 year ago)
K, Thanks for the tip! I'll give it a try.

I had been missing the log file because of typing "%temp%\Photosynther" at the "DOS" prompt.

Thanks again for the help,

M
sir_ivar (Over 1 year ago)
I think this might be a genuine bug.  Is there a limit to the site of the point cloud that can be uploaded?  

Here is the tail end of the log:

19:17:19 VtApp: Uploading "synth.bin" file C:\Users\Mark\AppData\Local\Temp\Photosynther\collection.synth.bin (30482505 bytes).
19:18:28 VtApp: CollectionUploader: UploadFile:Write failed hr(0x80072EFF), retry 0
19:19:43 VtApp: CollectionUploader: UploadFile:Write failed hr(0x80072EFF), retry 1
19:21:04 VtApp: CollectionUploader: UploadFile:Write failed hr(0x80072EFF), retry 2
19:22:29 VtApp: CollectionUploader: UploadFile:Write failed hr(0x80072EFF), retry 3
19:23:59 VtApp: CollectionUploader: UploadFile:Write failed hr(0x80072EFF), retry 4
19:25:33 VtApp: CollectionUploader: UploadFile:Write failed hr(0x80072EFF), retry 5
exception CollectionUploader.cpp(368) hr(0x80004004)
exception SynthPipeline.cpp(370) hr(0x80004004)
21:31:57 VtApp: ABORTED
Nathanael (Over 1 year ago)
I've bumped into this a few times as well. 

For me the issue is that the synther only retries five (or is it six, I suppose) times. While there may be legitimate reasons for this I have had times where I left the computer to crunch on a big synth and come back to find that for whatever reason my network connection on that PC has somehow developed a problem. By the time that I have sorted out the connection and gotten web access back up and running the retries have all been expended.

I also suppose that in the case above and perhaps even in my cases the 'Write failed' bit may refer to actually contacting the server and getting an error back from it, rather than simply being denied access out from the local machine. Is there a way to distinguish between the two cases?

I'm curious how it relates, mainly because Sir Ivar doesn't report any network connectivity problems.
sir_ivar (Over 1 year ago)
My interenet connection is stable and I hit the same error about half a dozen times over a couple of days.  Also tried dropping a lot of images and resynthing and still encountered the error.

I was able to upload another large synth of different subject matter without issue.  Who knows...
madeeds (Over 1 year ago)
If a synth takes more than a day to upload, there is a chance it will get interrupted in a way that might cause it to get stuck like this.  If this is happening, try creating some smaller synths of about 300-500 photos each.  These will get the photos uploaded, then you can create a synth of the whole thing.  

The upload cap is 40 MB so your 30 MB point cloud file should upload successfully.
sir_ivar (Over 1 year ago)
I experienced this problem again with another large synth.  I tried madeeds suggestions but the upload is hanging on collection.synth.bin file (which is just over 30mb in size) and not the upload of the images. 

Are you sure the upload upper limit is 40MB and not 30MB?

Also, I tried doing the upload from my mobile broadband as well as my LAN.  Both had the same problem so I don't think it's a connectivity issue.
sir_ivar (Over 1 year ago)
Just compared the two collection.synth.bin files from the two different synths that failed to upload.  Both have 363 bin files.  One is 29,541 KB and the other is 29,769 KB. Seems that I'm hitting some sort of limit....
Just an update for 2015: 

I've recently been trying some very low resolution copies of some photos that I took back in March of this year, since trying to synth all of the original photos at their native res always runs out of memory during scene reconstruction.

I had previously uploaded the originals in smaller consecutive sequences, since there were so many images at the location.

I also later tried uploading the photos in interpolated sequences to try to cover the entire environment (or logical segments of it) but thin the coverage to avoid running out of memory.

But recently I just wanted to see if I could get all of the camera positions in one synth, so I put 512px wide thumbnails of all 2,707 of the photos from my Wednesday shoot into one synth, 512px wide thumbnails of all 3,279 of the photos from my Saturday shoot into a second synth, and all 5,986 thumbnails from both days combined into a third synth.
My problem is that on the first synth (the smallest of the three) I have now computed it twice and both times it get stuck uploading the very last file.

The first time it uploaded all the photos fine, churned several hours on the reconstruction, created the deep zoom collection successfully, created the collection.bin successfully, uploaded the collection.synth.bin successfully, and then failed to upload the collection.dzcz at the very end.

The Synth Binary is tiny - only 4372502 bytes on attempt 1 and 4374361 bytes on attempt 2 (4 megabytes)
The Deep Zoom Collection is 47303695 bytes on attempt 1 and 47303694 bytes on attempt 2 (just under 48 megabytes)

I get 'experiencing a network error' reported in the synther and error 0x80072EFF printed out at the end of the log for both attempts of the first synth, but network connectivity is fine for all other programs and the synther just uploaded the collection.synth.bin file moments prior without error.
Here's the end of the first synth's log file for attempt 1: 

22:17:38 VtApp: Collection creation time: 1251.1
22:17:38 VtApp: Uploading "synth.bin" file C:\Users\Net\AppData\Local\Temp\Photosynther\collection.synth.bin (4372502 bytes).
22:17:38 VtApp: Autogeocoding synth at: 34.453548 -118.502320 with zoom level 17
22:19:20 VtApp: Upload finished
22:19:20 VtApp: Uploading "dzc" file C:\Users\Net\AppData\Local\Temp\Photosynther\collection.dzcz (47303695 bytes).
22:21:20 VtApp: CollectionUploader: UploadFile:Write failed hr(0x80072EFF), retry 0
22:23:26 VtApp: CollectionUploader: UploadFile:Write failed hr(0x80072EFF), retry 1
22:25:32 VtApp: CollectionUploader: UploadFile:Write failed hr(0x80072EFF), retry 2
22:27:50 VtApp: CollectionUploader: UploadFile:Write failed hr(0x80072EFF), retry 3
22:30:07 VtApp: CollectionUploader: UploadFile:Write failed hr(0x80072EFF), retry 4
22:32:32 VtApp: CollectionUploader: UploadFile:Write failed hr(0x80072EFF), retry 5
Here's the end of the first synth's log file for attempt 2: 

05:50:24 VtApp: Collection creation time: 1330.9
05:50:24 VtApp: Uploading "synth.bin" file C:\Users\Net\AppData\Local\Temp\Photosynther\collection.synth.bin (4374361 bytes).
05:50:25 VtApp: Autogeocoding synth at: 34.453548 -118.502320 with zoom level 17
05:51:08 VtApp: Upload finished
05:51:08 VtApp: Uploading "dzc" file C:\Users\Net\AppData\Local\Temp\Photosynther\collection.dzcz (47303694 bytes).
05:53:09 VtApp: CollectionUploader: UploadFile:Write failed hr(0x80072EFF), retry 0
05:55:15 VtApp: CollectionUploader: UploadFile:Write failed hr(0x80072EFF), retry 1
05:57:25 VtApp: CollectionUploader: UploadFile:Write failed hr(0x80072EFF), retry 2
05:59:45 VtApp: CollectionUploader: UploadFile:Write failed hr(0x80072EFF), retry 3
06:02:04 VtApp: CollectionUploader: UploadFile:Write failed hr(0x80072EFF), retry 4
06:04:31 VtApp: CollectionUploader: UploadFile:Write failed hr(0x80072EFF), retry 5
You need to be Signed In to add a comment. (Are you new? Sign Up for a free account.)