Topic: iPhone app crashes when trying to upload

Report Abuse Report Abuse
robskinn (Over 1 year ago)
When I sign into my Live account to upload the photosynth the app crashes back to iPhone springboard. It happens every time.
Any suggestions?
SteveGlenner (Over 1 year ago)
Hi Rob
I am sorry you are encountering this problem.
Is there anything unusual about your live ID account, such as was it created as a restricted account? Also, was your account associated with photosynth before you installed the app?
Is there any chance you could try this with an alternate live ID to see if the problem is related to your primary account?
Javier_Villanueva (Over 1 year ago)
I have exactly the same issue. I tried to sign in with 2 different live accounts with the same result.
SteveGlenner (Over 1 year ago)
Rob and Javier, and anyone else experiencing a crash, can you please tell us the iphone model and exact OS version number you are using.
Amandeeep (Over 1 year ago)
hi im havinf the same problem i tried with to different windows live ids but i crashes and goes back to home screen


IOS 4.3.2 (8H7)

Amandeeep (Over 1 year ago)
Can u please replie Steve
sWIGGUMs (Over 1 year ago)
Hi guys, having the same issue, I have 2 accounts. One I've used on photosynth before ( and the other I havnt ( Both crash when I try to log in. I can get to Facebook ok, and if I get the password wrong it dosent crash but obv that dosent help much!! 
On an iPhone 4 with the latest iOS 
Any ideas? I love the app otherwise!!
Amandeeep (Over 1 year ago)
That's exactly what's happening with me sWIGGUMs I even tried with 5other emails now

I really need to get them online

Otherwise the app is amazing
TonyErnst (Over 1 year ago)
Hey everyone, we're actively investigating this issue.  It would help if you could get the crash logs off your phone and email me any that begin with "Photosynth".  You can reach me at  

Amandeeep (Over 1 year ago)
Amandeeep (Over 1 year ago)
Wat are crash logs
Amandeeep (Over 1 year ago)
Tony I have sent u the crashlogs via email can u check them out
pacoregino (Over 1 year ago)
the same for me... iphone 3gs 4.3.2  the app is great but crashes every time i try to upload to my live account. =(
Amandeeep (Over 1 year ago)
Graphite (Over 1 year ago)
Same problem here. Using a 3GS running iOS 4.3.1. Jailbroken. 
Everything else seems to work fine until I try to upload. I'd prefer not to reinstall since I'd lose all the photos I've taken so far. 
I can share a crash log if it helps (and you tell me how to do that!)
masaemon (Over 1 year ago)
I have the same problem.
iPhone 4, iOS 4.3.2. no JB.
Where can i find the crash log?
Amandeeep (Over 1 year ago)
u dont need to find the crash logs anymore cause i have seny tony them
Amandeeep (Over 1 year ago)
to get info on how to get crash logs  go to
spencer.taylor (Over 1 year ago)
Having exactly the same issue here too.

A few moments after entering Window Live ID credential the app simply quits.

Using an iPhone 3GS on iOS 4.3.2
fgalizia (Over 1 year ago)
The same problem for me. Using an iPhone 4 iOS 4.3.2.
NateLawrence (Over 1 year ago)
Amandeeep, thank you for posting how to find the crash logs. I am sure that the Photosynth team can always use more of them, in case some people are having a slightly different problem, behind the scenes, than others.

A few days ago Tony Ernst from the Photosynth team said: 
"Hey everyone.  We've gotten a few crash logs from the phones of users who have been running into the login crash and we're actively investigating.  I'll post back here when we know more." 


"... the more information we have to go on the faster we'll be able to figure things out. ... Thanks"

This topic is a good place to keep up to date, but you can also check here for updates:
Carlosaguilera (Over 1 year ago)
I have the same problem, the application closes when I try to connect my

Additional information:
-I have a iPod Touch 4g iOS 4.3.2
-The connection is working properly facebook
-Im from México 
- My iPod is NOT Jailbreaked
cellarboy (Over 1 year ago)
I have the same problem with iphone
YMCA_Academy (Over 1 year ago)
Similar problem here, I checked "keep signed in" for Windows Live, now it crashes back to springboard 2-3 seconds after opening the app. Can't even get to settings to turn off Live login.

iPhone 4
4.3 (8F190)
deleta (Over 1 year ago)
I laso have the same problem.  Any development in the past 5 days?

I have an iPhone 4 with iOS 4.3.2
TonyErnst (Over 1 year ago)
Thanks to everyone who sent me their logs, they've definitely helped.  It seems that there are a small percentage of users that hit one of a few different, but related, issues causing the login crash. We're working on some fixes now and we'll be testing them soon.  I'll post back once we have a better idea for a release date, but it should be relatively soon.  

Keep the faith, we're working on it.
dmstrom (Over 1 year ago)
Tony, thanks! I love photosynth and use it regularly, but this problem drives me nuts. Look forward to the update!
Demmitri (Over 1 year ago)
THX Tony!!!!! I was gonna change to another option but i'll wait for the update!!! Please make us proud of showing off this app to our friends :)
Carlosaguilera (Over 1 year ago)
Thank you very much Tony! finally an answer in relation to the work being done to solve our problem, I look forward the update, and so your app will be really perfect and finally I could confidently recommend to all my contacts!!!
lumart (Over 1 year ago)
Suffering this same issue - iphone 4 running IOS 4.1. Expecting to have a solution soon
jfk21 (Over 1 year ago)
I am still experiencing the same problems. The app is useless, if I can not share them...

I am using 4.3.3 8J2, it also happened with the version before.
I am using a mail to sign up to windows live. It is located in Germany, I am not aware of any restrictions of my account.

The app crashes as soon as I try to log on to windows live. I can log on to facebook.

I will try to send you the crash log.

Any news concerning this bug?
jfk21 (Over 1 year ago)
just send a bunch of crash logs to using the current and the former os.
I hope they are useful.
Carlosaguilera (Over 1 year ago)
3 weeks and counting... really?? just to solve an id, a MIcrosoft ID problem??? ok, lets keep the faith for a little longer...
pixelfilm (Over 1 year ago)
still nothing? so hard to figure out the problem?:(
JuandeDios (Over 1 year ago)
I have the same problem, the application closes when I try to connect my account.

-I have a iPod Touch 4g iOS 4.3.1
-My iPod is NOT Jailbreaked
-Im from Lima-Peru.
yayadrian (Over 1 year ago)
Still facing this problem. 
Photosynth on the iPhone would be amazing, if only we could upload the results.
Acido (Over 1 year ago)
Dear Developers, any news on bug fix? I installed the iphone app, worked fine, then restored (after JB) iphone 4 w/4.3.3 and now it gets stuck on the splash screen with a little round loading thingy. software is awesome, I would really love to use it again.
Matulike (Over 1 year ago)
Same problem, as soon as I try to sign into my Windows Live ID the app crashes. Everything else is fine but I can't upload full 360degree interactive pictures without the Live ID. I will try to send a crash report. I'm using iPhone 3GS 4.3.3 jailbroken.
pixelfilm (Over 1 year ago)
So hard to fix the problem?
Ease give us some feedback. We are the users, you should inform us with the details.
Otherwise dont develop a software...
javiersq (Over 1 year ago)
I have and Iphone 4 iOS 4.3.3, without jailbreak, still does it!! Keeps crashing...
Carlosaguilera (Over 1 year ago)
This just shows how far you are to reach Apple. 

Is been more than 4 weeks from the first user in this forum officially reported the error when connecting Windows Live ID and you have not even solved a detail as small and as important in all this time.

You really have earned the reputation you have over the years with much certainty...
Here's the update: The bug occurs in an interaction between LiveID and the iOS keychain for certain accounts. We've fixed it, and the fix will be coming out in our 1.1 release which is currently scheduled for early-mid June. We looked hard for a workaround, but until we deploy this fix there's unfortunately no way to unstick the keychain. Sorry for the silence, but the solution is on its way.

David and the Photosynth Team.
javiersq (Over 1 year ago)
Great good news at last!!!
gravyboat (Over 1 year ago)
Any news on the update? I still can't log in and upload to my live account. App just quits on login
NateLawrence (Over 1 year ago)

Tony Ernst from the Photosynth team posted four days ago on the other big discussion on this issue: