Topic: Photosynth stuck in iOS update queue

Report Abuse Report Abuse
ExileStockholmer (Over 1 year ago)
I have made a lot of synths on my iPhone 4 but now I cannot access them since Photosynth is stuck on updating. I have tried may times on both 3G and Wifi. Other apps update OK. The phone runs the latest iOS version. 
If I remove and re-install the app, will I be able to keep my synths?

Best regards,
Daniel Nygren
Sweden (Over 1 year ago)
Hi ExileStockholmer,

Unfortunately if you reinstall the app, any data associated to it (including your panos) will be deleted.  You will only be able to keep the camera roll photos.  This sounds like it's related to the App Store update bug that occurred earlier this month. You might want to search around and see if there are any unofficial fixes that doesn't require reinstall, which are worth trying.
ExileStockholmer (Over 1 year ago)
Thanks for the reply. Unfortunately, I have had Photosynth stuck in the update queue for almost two months now. I cannot start it nor update it. The icon is tinted in dark grey and when I tap it, it says "Waiting" and then a dialog that says (roughly translated): "Photosynth could not be downloaded at this time". 
If I have to remove and reinstall, is there some way to restore the synths from a iPhone backup? Or is there some magic trick to cancel the update so I at least can continue using the app like it was before?
Thanks in advance!
ExileStockholmer (Over 1 year ago)
Still no solution? I made so many great synths, now they are inaccessible, and will be lost as I have to uninstall? Is that it?
Nathanael (Over 1 year ago)
ExileStockholmer, I would use something like iPhone Explorer to back up all of your captured panoramas which are on your device to your Windows/Mac machine. 

After all the files are safely backed up, then on your iPhone uninstall the Photosynth app, reinstall, then use iPhone Explorer to put your panoramas back on your phone and hope that the app sees them. 

That's the best that I can come up with.
Your fellow panner and synther, 
ExileStockholmer (Over 1 year ago)
Finally a potential solution. I'll try this ASAP.
Many thanks,