Topic: Failed installing Photosynth

Report Abuse Report Abuse
gea.ardi (Over 1 year ago)
Dear all,

I couldn't install the photosynth 2.11 that i've downloaded from I got the error message when the installation has reached "Finalizing Setup". The message said: 
"An error occurred during the installation of assembly Microsoft.vC90.OpenMP,version=9.0. 30729. 1,publicKeyToken=.1k8b3b9a le 18e3b’,processorArchitecture= x86,type=wwin32-. Please refer to Help and Support for more information. HRESULT: 0x80070002."

Please, somebody help me! Thanks for the help...
Nathanael (Over 1 year ago)
Try reading these two discussions to see if anything mentioned there helps and please reply back to let us know either way:
gea.ardi (Over 1 year ago)
Thanks for the respond Nathanael,

I've been checking the "Windows Modules Installer" and it's already running. Even if I stopped and restarted the service, I didn't receive any VC90 error. So I re run the installer and still got the same error.

I don't really understand with CBS.log, I tried to copy it, but just got another message: Access Denied.

So Nathanael, what I supposed to do next?
NateLawrence (Over 1 year ago)
Just to back up for a minute, can you confirm that you have installed ?
gea.ardi (Over 1 year ago)
Sorry, I forgot to say that I'm using x64 processor. Should I try the vcredist_x64?
NateLawrence (Over 1 year ago)
Ah... I'm going to have to try to get someone on the Photosynth team to chime in on that, but I'm guessing that because the Photosynth app is a 32bit application, it only needs the 32bit version of Visual C++ 2008 Redistributable Package.
gea.ardi (Over 1 year ago)

I've also tried to install Visual C++ 2008 for 64 bit. But it failed. It said Error 1905 and "HRESULT: 0x80070002" as installing the photosynth. I have to say, this Photosynth is very helpful tool for me as a geoscientist. We do take a lot of picture when we're on the field and we try to show the condition of the field at a small class room. Perhaps, the photosynth will help me a lot at my presentation, I will use this program to help me finishing my thesis.

So, Natelawrence, just let me know if you already have photosynth for 64bit. I do thank a lot. (Over 1 year ago)
Hi gea.ardi,

Unfortunately there is no single solution to this as certain system files are corrupted. I would recommend using a different machine or install a clean version Windows because you will probably to run into this same issue running MSI installers.  I have had a similar issue (for me I think it was from installing both Visual Studio Pro and Express).

If you want to try some of these solutions:

Lastly (and unofficially), if you install Photosynth on a different machine and copy the files in its program files (e.g. C:\Program Files\Photosynth) into your current machine--you might get away with it since it sounds like you have all the necessary supporting libraries.
NateLawrence (Over 1 year ago)
gea.ardi, Adrian is on the Photosynth team, so I'll let him handle this from here.