Topic: problem login windows live id

Report Abuse Report Abuse
luizo (Over 1 year ago)
evrytime i try to sign in with the windows live account on the iphone app, it crashes, facebook sign in its ok but the WL id crashes , i really want to share my interactives panoramas
robskinn (Over 1 year ago)
Same here. I'm using an iPhone 4 ios 4.3.1
SteveGlenner (Over 1 year ago)
Hi photosynth app developer here.
I am sorry you are running into this problem. I don't think this was run into as a general issue before release.
If you sync your phone with itunes desktop app, then we will eventually get a crash report from apple which would help us diagnose the issue.
Have you tried entering your windows live login from the settings page on the app, or are you logging in directly from the sharing screen?
Is there anything unusual about your live ID, like it was created as a child account or other restricted account?
Have you ever uploaded to photosynth previously?
I am trying to understand if the problem is with live login or with provisioning of photosynth accounts.
Also, and this is really just a randon suggestion, but you might try changing your password from a browser and then try logging in on the photosynth app. I don't know that this will work but I have had to use manual reset on live passwords in the past to fix some issues
Lit (Over 1 year ago)
Is you Windows Live ID:
or other non-Microsoft addresses?  What country is your Windows Live ID set to?  Just want to get more info to see if we can reproduce the problem here.  Thanks.
berch (Over 1 year ago)
hi there, i just downloaded the app this morning and i have exactly the same problem, sign in and the app crashes, not tried the facebook sign in yet
berch (Over 1 year ago)
If it helps i have an @hotmail. Com account and sign in frpm ireland
I use an iphone 4 with the latest os
SalvadorGDA (Over 1 year ago)
I have the same problem, when I try to login to my account the app crashes.
Iphone 4 iOS 4.3.2
nicmitham (Over 1 year ago)
same problem using a email address. come on guys, get this sorted please
mrveeee (Over 1 year ago)
I have same problem and I have an aol email address... frustrating !!!!
tokygun (Over 1 year ago)
same here with address!
berch (Over 1 year ago)
Facebook login not working for me either
TonyErnst (Over 1 year ago)
Hey everyone.  We've gotten a few crash logs from the phones of users who have been running into the login crash and we're actively investigating.  Ill post back here when we know more.

Tony Ernst
Photosynth Test Lead
TonyErnst (Over 1 year ago)
Please feel free to email me your crash logs - the more information we have to go on the faster we'll be able to figure things out.

ricardoap (Over 1 year ago)
I have Photosynth en my Iphone. I have last version IOS. I have msn acount and an account in
I do a photosynth, but when I want to upload to, I sign windows live id using my msn account. I write my windows ID and my password, I click connect but them photosynth close.
I erase photosynth and again install photosynth,  but the problem still continues. I restart my iphone, but nothing, the problem still continues
What will be the problem ?
Soryy my bad English
stubbo66 (Over 1 year ago)
Mines slightly different, it doesn't crash but it says my id or password are invalid, yet when I click on the link to create an ID it logs straight in to my account in the browser and shows all my details.

So I won't get a crash dump, it just won't let me log in through the app.
woonich (Over 1 year ago)
I have the same problem. I tried it with 4.3.1 and 4.3.2, with @hotmail and @live ID, from the settings page on the app and from the sharing page,  and it's always crashing. when the password is wrong the app doesn't crash, otherwise when it is good it crash. I tried to delete the app and download it again, without good result ... facebook login works
woonich (Over 1 year ago)
I forgot, I have iPhone 4. By the way, I also tried changing my I password.
woonich (Over 1 year ago)
ID password from the browser ...
bendy (Over 1 year ago)
Yup same crashing here :-(
ReflectedGlory (Over 1 year ago)
I am getting the same problem on my iPhone 4.

Some additional info 
- my live ID is based on an old account (can successfully log on to in a browser)
- i don't think photosynth is actually crashing; though the app closes and doesnt log on,  it continues to run in the background
ReflectedGlory (Over 1 year ago)
One more thing - I can log on with those details from photosynth on my ipad2
dshirlaw (Over 1 year ago)
Glad I'm not the only one with this problem - doesn't matter where you try to login - share link or settings - result is still the same. App crashes after entering Live ID
Carlosaguilera (Over 1 year ago)
I have the same problem, the application closes when I try to connect my

Additional information:
-I have a iPod Touch 4g iOS 4.3.2
-The connection is working properly facebook
-Im from México
Carlosaguilera (Over 1 year ago)
- My iPod is NOT Jailbreaked
Carlosaguilera (Over 1 year ago)
-My account is
Carlosaguilera (Over 1 year ago)
Please let us know some news... I'm on the lookout every day at this forum since I install the app
conxxion1 (Over 1 year ago)
I get the same problem too.
Amandeeep (Over 1 year ago)
im also on the lookout will u please tell us some info
telekin (Over 1 year ago)
Same thing.... is there a solution???!
sensecam (Over 1 year ago)
I have had same bug. Is there a work around to upload image from iphone via a PC please? I would like to upload panorama to Facebook.
Md.griff (Over 1 year ago)
Works on my mums iphone which is one of the older ones, the round edged ones? my iphone 4 crashes like everyone else has said. logs in to facebook but when you click connect on live sign in it just closes. how annoying, would really like to share panoramas to facebook!! fixxxxxx!!!
Carlosaguilera (Over 1 year ago)
Come on, someone from Microsoft could answer? at least tell us if someone is reading us....
Amandeeep (Over 1 year ago)
they r reading u there trying hard
Demmitri (Over 1 year ago)
Seriously, are you gonna fix this??? I cant share a single panorama because the app keeps crashing. It was a good idea, but if this continues, people will reconsiderate another option.
djpechi (Over 1 year ago)
Hi I'm having this same issue, can connect to Facebook but can't log in to windows live, after writing my hotmail and password the app crashes, I'm using iPhone 4 with 4.3.1, I can share my crash log if you ask.

Thanks hope we can find a solution to this :S
Carlosaguilera (Over 1 year ago)
TT3000 (Over 1 year ago)
same problem here
and its a shame that you cant re use an old pano picture that photosynth created before i re installed it.
FazJay (Over 1 year ago)
Hi, having the problems logging in with my live ID also. 

I thought it was because my email is the non-standard Microsoft version. 

But having read all these comments above, I can see it's an issue not connected with email type. 

Can someone provide an update as to whats going on? It has been a month now and I'm still waiting. Hope you guys find the fix soon. 

BTW the apps UI is great! I see you used the theme from Windows Phone 7. It's growing on me, and I'm tempted to get one myself. Hope these bugs get fixed first though.
hugonicolas (Over 1 year ago)
same problem with iphone 4 last IOS, please fixit
elemi93 (Over 1 year ago)
The same problem, iPhone 3Gs, iOS 4.3.3
Carlosaguilera (Over 1 year ago)
This just shows how far you are to reach Apple. 

Is been more than 4 weeks from the first user in this forum officially reported the error when connecting Windows Live ID and you have not even solved a detail as small and as important in all this time.

You really have earned the reputation you have over the years with much certainty...
Here's the update: The bug occurs in an interaction between LiveID and the iOS keychain for certain accounts. We've fixed it, and the fix will be coming out in our 1.1 release which is currently scheduled for early-mid June. We looked hard for a workaround, but until we deploy this fix there's unfortunately no way to unstick the keychain. Sorry for the silence, but the solution is on its way.

David and the Photosynth Team
Md.griff (Over 1 year ago)
That's fairly slack... Such a great app and so simple to use but rendered useless to the majority of people because you just can't upload?!? Look forward to the update and being able to share the panoramas on Facebook.
NateLawrence (Over 1 year ago)
Md.griff, I know that a fair number of people have had this error (as evidenced by this conversation and a similar one in the Bugs forum), but my impression has been that the vast majority of people who have downloaded the app do not have this problem, but instead only a very small percentage of the total users. Perhaps I am mistaken.

Then again, even a small percentage of millions of users is still quite a lot of people affected.
TonyErnst (Over 1 year ago)
Md.griff - this is only affecting a very small percentage of users.  Given that you happen to be one of them Im sure you dont feel any better knowing this though.  The update will be out in the next couple weeks and you'll be able to share your panoramas with the world.
NeufNeuf (Over 1 year ago)
I have the same problem but with Facebook.  Click "share", then white Facebook login page comes up, the twirly thing twirls for two secs & then it goes away leaving the white login page forever more...  Go to settings page & try to log into Facebook there & same happens......... rather annoying.  Yet Windows Live says: "Logout" in blue meaning it is logged in fine.  Will this problem also be fixed in the next revision?  I shared on Facebook absolutely fine until a week ago!
NateLawrence (Over 1 year ago)
@NeufNeuf, the Facebook login problem is on Facebook's end and they are working on fixing it.

For updates on the Facebook Connect problems, please check one of these two discussions: (They have a temporary workaround for you.)
TonyErnst (Over 1 year ago)
FYI - Facebook fixed their issue this morning
rom.mendoza (Over 1 year ago)
Liking the app but can't log into my windows live acct. Every time I try I am getting "invalid username or password". I was able to log into here so I'm pretty sure I have the right username and password.  I am using my email address as my windows live id. Should it be something else?
jbryner (Over 1 year ago)
Mine doesn't crash, but when I attempt to login to Windows Live through the Photosyth app (or even the Bing app), I enter my login info but none of the buttons work.  Connect and Cancel are "grayed out" and "Go" on the keyboard does nothing.   The app doesn't crash, though I wish it would because I have to go out and double-tap home to quit the app.  There's not a way to close the login screen once it's open, since the Cancel is grayed out.  

TonyErnst (Over 1 year ago)
Be on the lookout for an update to the Photosynth app in the next week or two that should fix your liveid signin problem.
Trenarren (Over 1 year ago)
yea, looks like a brilliant app! but it doesn't work as I cant log into my account, it just crashes! Any news of the update?
denysvon (Over 1 year ago)
I have the same problem cant login Windows live the app quits iPhone 4 4.3.3
TonyErnst (Over 1 year ago)
The 1.1 update is available in the app store as of today. It should fix the liveid login crash issue. Please let me know immediately if you're still seeing it after installing the update.
krisb78 (Over 1 year ago)
Hi there. Downloaded the update. App now no longer crashes when try to login with a address. However, it still doesn't login. A couple of other screens quickly flash up but it still shows as not connected. iPhone 4.
krisb78 (Over 1 year ago)
Hi again. Update to the last. After 3 failed attempts it eventually logged on!
jon-wolf (Over 1 year ago)
Still not logging in for me!!
Carlosaguilera (Over 1 year ago)
The upgrade work for me correctly! 

I did not think that I would return to this forum because I felt quite disappointed to see the weeks went by and we all had no response from those responsible for support, even to say hello, but I must say I take that back, and be happy now widely committee recommends your application! and expand your database with photographs from my panoramas to this site and for Bing maps 

Sincerely thank you very much! 
although it would be nice if you pay more attention to this forum, we just needed to know that we were not talking to themselves.
kevinpurcell (Over 1 year ago)
For me the connect button will not work. Still broken.
JonnyClark (Over 1 year ago)
I've updated to 1.1 but still can't login to Live account. The app doesn't crash, it just reports that it's not logged in. I created the account recently and can login OK from normal browser.
bodyluna (Over 1 year ago)
Hello, i just download the 1.1 version and i cant loggin on my iphone 4 with my account to share.The app doesn't crash, it just reports that it's not logged in.
Thanks to fix that "Big" problem for us !!! and thanks for your work, its great !
CooperNick (Over 1 year ago)
iOS 4.3.1, photosynth 1.1 - "Invalid username or password"
Just istalled 4.3.3, photosynth 1.1

Live ID on:

- can't login
wi-fi or GPRS

My country is specified as Russia (in Apple ID)
I'm from Kiev/Ukraine
SicaFilms (Over 1 year ago)
Connect button, and all other button on Login screen is dead. Cannot login with live id. On iPhone 5, iOS 5 Beta 4
perolof (Over 1 year ago)
Connect button, and all other button on Login screen is dead. Cannot login with live id. On iPhone 3g3, iOS 5 Beta 4
i.ason (Over 1 year ago)
the web view for login doesn't react to any touch. i even can't dismiss the view and have to restart the app.
i.ason (Over 1 year ago)
btw.: I'm using the ios5 beta.. maybe thats causing the bug
CleverBoy (Over 1 year ago)

I'm running into the EXACT same problem that's been bubbling up here.

NO CRASHES.  It simply refuses to login to with my Windows Live account.  This wouldn't be so bad if there were any OTHER way of uploading your Photosynths to the site... but their aren't.  At least as far as I know.

I just created a Windows Live account today for this purpose.  Wouldn't use my old one either.

It seems to ME, that this is just a simple matter of the login FORM not submitting.

I'm a web developer, and from all appearances, it doesn't appear to attempt to SEND any login details anywhere.  The form simply sits there.  The Live ID and Password boxes work fine.  The "Keep my Logged in" checkbox works fine.

But, when the login "Connect" button is tapped... Nothing.  When "GO" is tabbed on the virtual keyboard... Nothing.  It's very frustrating.  You guys should just allow the Photosynth to be emailed to yourself and uploaded in a zip file or something.
CleverBoy (Over 1 year ago)
Technical note: I'm a developer, so I'm running iOS 5 beta 3. But, there feels like there shouldn't be a reason for this not to work.

Here's a clue though!

I just went into Bing Maps, and tapped "Manage Sign Ins", and "Windows Live", then "Sign Up".  It throws me into Mobile Safari, and then... after numerous redirects... and ERROR PAGE.  It says:

"Sorry, it looks like there was an error.  Please try again."

Are you guys certain the internal pages that control logging in aren't accidentally redirecting because of the mobile browser, and sending us all to ERROR pages we can't see?

In general, there seems to be awkwardness across the board about whether you're logged in or not.

Also, the Sign Up, Privacy, and Terms links on the Windows Live sign in pop-up don't appear functional.
Nathanael (Over 1 year ago)
CleverBoy, I can't speak on the Photosynth team's behalf, however here are a couple of observations.

The app crashing when trying to log in was a separate bug which is detailed above and was resolved in the 1.1 version of the app. Unfortunately, people have been mistakenly reporting separate bugs (invalid credentials, unresponsive UI) in this same discussion.

I don't have any insight on the invalid username/password issue (though it is not widely reported). The locked interface on the login screen, however, seems to only manifest itself on iOS5 Beta. Within hours of the keynote at WWDC, though, I saw tweets hit my Twitter search for Photosynth complaining that iOS5 Beta breaks Photosynth. I am not saying that there is a great reason, but it seems to me that this exactly the sort of thing that you sign up for when you decide to run beta software. As a developer, I'm sure that you can understand waiting for a stable build of the OS to target for bugfixes.
CleverBoy (Over 1 year ago)
Nathaniel... with due respect to the Photosynth team, there appears to be obvious problems with this login procedure regardless of what iOS version I'm running.  It's the same login (by appearances) used in the Bing app.  

I don't think you can fault the beta, as Facebook's method works perfectly fine.  In troubleshooting this myself, I noticed that the first authentication address passed from my phone ends the URL with "firstRun=false".  If I leave it this way, and run the entire address in my browser... 

I get an EMPTY XML result.  If, however, I change "firstRun" to "true", I get a userid XML document... presumably signaling a successful login.  My feeling is that this problem should be easy to debug and correct (esp. if its fixable on the server side).  I'm going to attempt to use a httpproxy to "fix" that first call to the server to read "firstRun=true" and see if Photosynth likes it.

I just wish this would work.
Nathanael (Over 1 year ago)
Am I understanding you correctly that you experience this same bug on iOS 4? 

I just keep trying to figure out what the common factor is between people who are experiencing this unresponsive login UI. You say that there is obviously something amiss with the login procedure and I'm sure that for people who can't shake the bug it is extremely vexing. All I know is that most users don't experience this error as I see plenty of mobile panos successfully uploaded each day and shared on Twitter. 

It often seems to me that users who are experiencing a bug assume that their experience is universal. Perhaps you didn't mean to come across that way. My question is only what is different about your device as opposed to most folks'? I agree that the bug exists and needs to be fixed. It just seems to be affecting a very small percentage of total users.

I didn't mean to imply that the iOS5 beta would break all logins, but there did seem to be a correlation for WLID.
alexbarreras (Over 1 year ago)
Hi... CleverBoy thanks for the light you are sending photosynth team. I am using iOS5 beta 5 and I can't login, neither with the previous iOs5 beta versions. This is very uncomfortable because I have explendid pics to share and I can't do anything!!! Is there a way to extract the pics and upload manually to or create a backup???

Thanks photosynth team... Pls solve this asap...
Guys -- it's true. The iOS5 betas break Windows Live ID login, at least the version of the code we were using on iOS4.

We will release a Photosynth 1.1.1 coordinated with the official iOS5 that will address this issue and a few others we've found.

We'll know when this update will come when Apple announces its release date for iOS5. We won't be doing the release until we are sure we've seen the last pre-release beta, so until then please run Photosynth on iOS4 if you want to upload.

David Gedye
Photosynth Lead PM.
jon-wolf (Over 1 year ago)
Just updated to ios 5 beta 7 and it works fine logs into my live ID no problems.
alexbarreras (Over 1 year ago)
Me too! Now with iOS5 Beta 5 works fine!
Maesek (Over 1 year ago)
Just installed new version and have the same problem. Not sign in to wl. My email is @yahoo ans after fill email and password, the input data page comes down and a new page comes up very quick, with just one text space, then iphone keyboard appears and quickly comes down. After that saids wl not connected
Nathanael (Over 1 year ago)
For anyone who is just having a problem with signing in with their Windows Live ID, try resetting your Windows Live password at 

After you save your new password, try signing into the app again and see if it works.
OllieDale (Over 1 year ago)
When I try to send to Facebook (iPhone4), PhotoSynth crashes, despite reset WindowsLive passwords, iOS updates (5.0.1), and licking my finger and pointing it at the sky... Is there a fix coming or should I just not bother?
NateLawrence (Over 1 year ago)
For the record, OllieDale started their own topic and got a first reply from Photosynth head honcho, David Gedye, here:
alensiljak (Over 1 year ago)
I had a similar issue, where I could not log in with Live ID.
The reason was that the password I had was 32 characters long. This is effectively masked by passport site (and in the browser login). Passport (Live Id) stores 16-character passwords only.
Photosynth tries to log in with 32-character long one and fails authentication. When I manually copied only the first 16 characters of the password, it went through.
Hope this is clear enough.
jenkweb (Over 1 year ago)
Just tried this and yes the app will only take the first 16 characters of my live id password. I tried that and I finally got signed in. This is strange since xbox live app on the same phone authenticates fine with the longer password.
Freak3D (Over 1 year ago)
With Photosynth i can not login yet this is the very 
same login for this forum. I am using an iPhone4
And have no idea how i would empty any cache!
Like the app very much but is this just another hard work
PC app, shurely it could be put on the list of things
To fix? Perhaps it could be done relativley soon.
Freak3D (Over 1 year ago)
Just changed my password that had 
17 characters and a full stop. Yeah just like that
one. Now its 7 characters, letters only and numerals
only. Now i can login and i have solved my
problem for now. Hope this helps some of you.
Nathanael (Over 1 year ago)
Freak3D, the full stop shouldn't be a problem, but for years and years Live ID has only supported 16 character passwords. 

Again, anyone who is having problem logging in with their Live ID can go to which will automatically limit you to a 16 character password when you enter your new password.
WildWood (Over 1 year ago)
I'm so pleased I found these comments from you all! Have been using Photosynth without problems for just over a year. Superb app. Love it. Changed my windows live password today to find I couldn't login in anymore using my windows live ID. Have been messing around for hours. Saw this last comment about only using 16 characters (my password has 17, not that I'd bothered counting them before now). Dropped the last character and it worked fine. Still require 17 characters on my laptop but on the iPhone 4 it's worked absolutely fine. Thank you!!
fabsio (Over 1 year ago)
Here is something that you can use to reset the password
michael2013 (Over 1 year ago)
The similar problem also happens with my Surface Pro 2. Eventually I unlock my Microsoft account logon credential using PCUnlocker.